John's Blog: Older Rumpus, Newer OS

June 20, 2019

Question: I am currently running an older version of Rumpus, and would like to upgrade the server OS. Is my older Rumpus version compatible with the newer OS release?

This is a common question, and one for which I don't have a definitive answer. But the simple answer is, "Probably not. You should upgrade Rumpus along with the Operating System".

When new versions of Mac OS or Windows are released, we don't go back and test obsolete versions of Rumpus for compatibility, so we really can't say for sure whether or not those older versions will run on the new OS. But I can tell you that it is very common for us to update Rumpus to maintain compatibility when new OS releases come out. In particular, newer OS releases often have stricter or updated security policies that require updates. There are other changes too, including obsolete or changed features in the system, updates to sub-systems like SSL, SSH and the like, new UI capabilities that need to be accounted for, etc. that cause Maxum to keep Rumpus up to date.

So, when new Operating Systems are released, we always perform extensive compatibility testing, and update Rumpus as needed. For obvious reasons, Maxum can't go back and perform all of these updates on past versions of the Rumpus software.

Even if an older version of Rumpus will technically run on a newer OS, the best practice is certainly to update Rumpus along with the OS, anyway. Even if your Rumpus server is running perfectly (and I certainly hope that it is!), staying current makes sense. Web browsers and other file transfer clients continue to evolve, providing improved security and features, and it is important for the server side to stay current to maintain these evolving standards. When it's time to upgrade the OS, it makes for the perfect opportunity to update the Rumpus software, too.

© Copyright 2019, Maxum Development Corp.